ICT

Information and Communication Technology

ICT includes technologies such as desktop and laptop computers, software, peripherals and connections to the Internet that are intended to fulfil information processing and communications functions.

The Main Parts of a Computer System

- **The System Unit**
- **VDU (Monitor)**
- **Speakers**
- **Keyboard**
- **Mouse**

Hardware and Software

The term **Hardware** refers to the things that you can see and touch like the **system unit, mouse, keyboard, monitor etc.**

The **Software** refers to instructions that make the computer work. You cannot see or touch it. Software is held either on your computer’s hard disk, CD/DVD-ROM, or on a Flash Drive and is loaded (copied) from the disk into the computers RAM (Random Access Memory) when needed.

E.g. **Microsoft Windows, Microsoft Word, AVG Antivirus and Adobe Acrobat Reader.**

© Mr. J. Buğeda B.A. (Gen), P.G.C.E., Dip.CS.Ed.
The Main Input Devices

The mouse:
A mouse has at least two buttons - left and right. Some have a middle button or a scroll wheel between the left and right buttons. The left button is used the most. The right button normally opens a menu.

- The normal shape for the mouse pointer is an arrow.
- If you see the following mouse pointers or it means that you have to wait until it becomes an arrow again.

What Can You Do with a Mouse?

- Move the pointer/cursor
  Moving the mouse around moves the mouse pointer on the screen.

- Click (single click)
  Press a mouse button and release it. Usually the left button.

- Double-click
  Press a mouse button twice quickly.

- Drag
  Hold a mouse button down while moving the mouse. Usually what the mouse pointer was over on the screen will move or be highlighted when you drag.

- Scroll
  Rolling the wheel that some mice have will scroll the document in the current window.

Left or Right click?
When the instructions say:
- click or double click — it always means LEFT click
- Right click — it means single RIGHT click

Selecting (taghēl)
Click ONCE to select something — before for example cutting, copying or deleting.
The Computer Keyboard

The Keyboard can be divided into three parts:

1. The QWERTY keyboard which is exactly the same as a typewriter – also called **alphanumeric**.

2. The Numeric Key pad used for **numeric** calculations.

3. The Special **function** keys.

---

Some popular Keys:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Caps Lock</strong></td>
<td>To write whole sentences in capitals, just press it once. Press Caps Lock again when you want to stop typing in capitals.</td>
</tr>
<tr>
<td><strong>Shift Key</strong></td>
<td>As long as you hold this down, all the letters you type will be in capitals.</td>
</tr>
<tr>
<td><strong>Backspace</strong></td>
<td>To delete the letters to the <strong>left</strong> of where the cursor is flashing</td>
</tr>
<tr>
<td><strong>Delete</strong></td>
<td>To delete the letters to the <strong>right</strong> of where the cursor is flashing</td>
</tr>
<tr>
<td><strong>Space Bar</strong></td>
<td>To insert a space between characters</td>
</tr>
<tr>
<td><strong>Enter Key</strong></td>
<td>To start a fresh line. There are two <strong>Enter</strong> keys, one marked with a bent arrow and the other marked ‘Enter’. They both do the same thing.</td>
</tr>
</tbody>
</table>
What is the Start Button?
A single **click** of the left-hand mouse button on the **Start button** will display the **Start menu**.

The Start Menu
The Start menu contains the various categories where you can find applications (*programmi bial Word, Excel u Paint*) and stored work.

The First Steps with the Computer

**Start the computer**

After a few seconds, you should see something on the screen. If not, check if the monitor is switched on.

- You may be asked to supply a logon ID and a password (In the school computer lab 2, the logon ID is *lab2* and the password is *lab2*).

**Shut down the computer correctly**

1. Save any files you may have been working and close any open applications.
2. Click on the **Start** Button

   1. Use the **Turn Off Computer** (*in case of Windows XP Home Edition*) or **Shut down** (*in case of Windows XP Professional*) command to close down the system.

2. Then select the **Turn Off** button or choose **Shutdown** and click **Ok**

   The computer will automatically turn itself off once the shutdown sequence is complete.
- Never switch off your computer from the Switch on the Tower!

'Turn Off Computer' Options
The 'Turn Computer Off' option allows the user to close down the Windows operating system cleanly so that any unsaved data may be saved to your hard disk. Several options are available when shutting down the computer:

Turn Off: Allows you to save any unsaved data to disk and closes the computer down.

Restart: Allows you to save any unsaved data to disk and then restarts the computer.

Restart the computer using an appropriate routine.

To restart your computer:
1. Click on the Start icon.
2. Click on the Turn Off Computer/Shutdown button.
3. Click on the Restart button / Select Restart from the drop-down menu

What is a Dialog Box?
A box that appears on a display screen to present information or request input. Typically, dialog boxes are temporary -- they disappear once you have entered the requested information.

Examples:
The Graphical User Interface (GUI)

The Graphical User Interface uses icons and a mouse pointer. It uses the Visual Display Unit (VDU or monitor) as the main output device. The Desktop below is a clear example of a Graphical User Interface:

The Parts of a Window

- **Title Bar**
- **Menu Bar**
- **Tool Bar**
- **Status Bar**
- **Minimise**
- **Maximise/Restore down**
- **Close**
- **Scroll Bar**
Recognising different icons:

- Hard disk (HDD)
- CD/DVD-RAM drive
- USB Flash drive
- Folders
- Files
- Printer
- Applications (Programs)

Saving to a USB flash drive or a Folder (directory) in the Hard Disk

1. Click File | Save
2. Click My Computer to list all disk drives
3. Choose the drive WHERE you are going to save.
4. Click here and write name you want to give to the file.
5. Click Save

Note:
To Save again after making some changes, go to File -> Save
To Save somewhere else, go to File -> Save As

To Print a document from a text editing program

To print from an application (program) click on the printer icon in the tool bar.

If you click File -> Print, you can choose more options e.g. how many copies to print.
Word Processing

To open Microsoft Word:
1. Click on Start on the Taskbar
2. Click on All Programs -> Microsoft Office -> Microsoft Office Word 2003

To close the Word Processor

Click on the Close icon displayed at the top right of the Microsoft Word window

If you have not saved your work, a dialog box will be displayed which asks you if you wish to save your changes. Make your choice from one of the following:

Yes: Saves the changes and exits the program.

No: Does not save the changes and exits the program. Choosing No will lose any work which you have done since you last saved the file.

Cancel: Cancels the command and stays in the Word program.

Insert or Overwrite

In Insert mode text is added to a document without overwriting anything else. In Overtype mode it will overwrite existing text with any new text which you type in. The status bar at the bottom of the Word window indicates that you are in Overtype mode by highlighting the OVR indicator.

To switch between Insert and Overtype, press the Insert button on the keyboard or double click on OVR on the status bar.

To erase a letter:

Click near the letter that you want to erase:

To erase letters to the right press:

To erase letters to the left press backspace:
Why is it important to SELECT/HIGHLIGHT?

In many cases you need to select something within Word (such as a line of text), before applying formatting information to the selected item!

To select a character

1. Click just in front of the character you want to select.
2. Press the Shift key (and keep it pressed).
3. Press the right arrow key.
4. Release the Shift key.

To select a word

• Double click on the word.

To select a line

1. Move the mouse pointer to the left of the line which you wish to select, until the mouse pointer changes from an I bar to an arrow pointing upwards and to the right.
2. Click once with the mouse button to select the line.

To select a sentence

1. Move the mouse pointer within the sentence which you wish to select.
2. Depress the Ctrl key and then click within the sentence.

To select a paragraph

• Move the mouse pointer within the paragraph which you wish to select and click three times (very quickly).

Copying, Cutting and Pasting

Moving & Copying Text
The Word Processor uses a temporary storage area called the clipboard for moving and copying text within a document.

To move text:

1. Select the text to move.
2. Click Cut button or press Ctrl+X
3. Position the cursor where the text will be moved.
4. Click the Paste button or press Ctrl+V

Note that:

The Cut button removes the selected text or object and places it on the Clipboard, where you cannot see it on screen.
To copy text:
1. Select the text to copy.
2. Click Copy button or press Ctrl+C.
3. Position the cursor where the text will be copied.
4. Click Paste button or press Ctrl+V.

Note:
You can even cut-paste or copy-paste information from one document to another, and to and from other programs, such as the spreadsheet program.

Creating / Merging Paragraphs

To start a new paragraph press ENTER key. The cursor moves to the next line where you can start typing the text making the new paragraph.

To merge i.e. join two paragraphs in a single paragraph:
1. Place the cursor to the left of the second paragraph i.e. just before the first letter of the second paragraph.
2. Press Backspace key until the second paragraph moves just after the first paragraph.

Show/Hide Toolbars

To get back a missing toolbar
1. Click View—>Toolbars
2. Tick the name of the toolbar that you wish to show.

To hide a toolbar follow step 1 above and then un-tick the name of the toolbar you wish to hide.

The Zoom feature

This feature allows you to enlarge or reduce the view of a page on the screen. You can show the whole page, or just a section of it.

To zoom a document using the Zoom icon

Use the Zoom icon on the Standard toolbar to zoom quickly. Click on the down arrow next to the Zoom icon to display a drop down list of pre-set screen zoom values.

NOTE: You can enter any value you like, you do not have to accept the values offered to you.
Use **Undo** to reverse your last actions

- From the **Edit** menu choose the **Undo** command
- OR press **Ctrl+Z**
- OR click on the Undo button on the Standard toolbar.

Repeat as required to perform multiple undo actions.

---

**The Formatting Toolbar:**

- **Font type**
- **Font size**
- **Bold**
- **Italics**
- **Underline**
- **Font Colour**
  1. Click here to open the drop-down menu
  2. Choose a colour from here

**Alignment of text:**

- **left**
- **centre**
- **right**
- **justify**

---

If you have pressed the undo button more times than needed, you can press the **Redo** button to undo you last undo.
To apply **subscript** or **superscript** formatting

1. Select the text which you wish to format as subscript or superscript.
2. From the **Format** menu, choose the **Font** command. The **Font** dialog box is displayed.
3. From within the **Effects** section of the dialog box, select either the **Subscript** or **Superscript** command.

**Subscript:** Text is lowered below its normal position on the text line. Take as an example the chemical formula for water. If we type in **H2O**, it is not formatted correctly. We need to select the 2 within the formula and then format it as subscript.

![Subscript Example](before_after.png)

**Superscript:** Text is raised above its normal position on the text line. Take as an example Albert Einstein’s famous formula relating mass and energy. If we type in **E=MC2**, it is not formatted correctly. We need to select the 2 within the formula and then format it as superscript.

![Superscript Example](before_after.png)

To change the text case

1. Select the text of which you wish to change the case.
2. Click on the **Format** drop down menu and select the **Change Case** command.
3. From the dialog box displayed, select the required case, and then click on the **OK** button.

Inserting Objects in a Word Document

1. Click **Insert** on the **Menu Bar**.
2. Select **Picture** from the **Insert** menu.
Pictures, Images and Charts

Using pictures within Word
Word is a graphical word-processor. This means that as well as allowing you to type text into Word you can also insert pictures. These pictures may take the form of clip art (a gallery of picture images which is supplied with Word), graphs (charts) or even movies! Make the best of these features, they can really brighten up your documents!

Insert a picture, an image, a chart into a document.

To insert Clipart
Make sure that the Drawing toolbar is displayed. If it is not, then click on the Drawing icon displayed within the Standard toolbar.

1. Click at the location where you wish to insert the clipart picture.
2. Click on the Insert Clip Art icon, located in the Drawing toolbar.
3. You will see the Clip Art options displayed to the right of your screen.
4. In the Search section enter a search word such as 'bird'. Then click on the Search button. Matching Clip Art will be displayed, as illustrated:
5. Click on the picture you like to insert it into your document

If necessary use the scroll bars to display the required picture

To find a picture of something else, such as 'flower' click modify to search again.
To insert a picture (ritratt) held as a file on your hard disk

1. Click within your document at the location where you wish to insert the picture.
2. Click on the Insert drop down menu and select the Picture command.
3. From the submenu displayed, select From File.
4. Use the dialog box which is displayed to select the required file. You may have to select a different drive or folder if the file is stored in a different location. You will see a preview of the selected file, as illustrated.
5. Once you have selected the required file, click on the Insert button.

To insert a chart into a document

1. Click at the location within the document where you wish to insert the chart.
2. Click on the Insert drop down menu and select the Picture command. From the submenu click on Chart.
3. A chart will be inserted into the document.

To insert a drawn object (New Drawing) into a document

1. Click at the location within the document where you wish to insert the New Drawing.
2. Click on the Insert drop down menu and select the Picture command. From the submenu click on New Drawing.
3. A drawing canvas will show in your document.
4. Choose Autoshapes, lines, arrows, circles etc. from the **Drawing toolbar** shown to draw your new drawing inside the Drawing Canvas.

---

### Select a picture, image, chart in a document

**To select a graphic**
Click once on the graphic. The selected graphic is surrounded by 8 'handles' (small black squares) as illustrated. The same technique applies to pictures, images or charts.

### Move a picture, image, chart within a document

**To move a graphic within a document**

1. Select the graphic you wish to move by clicking on it once.
2. Click on the **Edit** drop down menu and select the **Cut** command.
3. Click within the document at the location to which you wish to move the graphic.
4. Click on the **Edit** drop down menu and select the **Paste** command.

### Resize a picture, image, chart

**To resize (tkabbar jew iċċekken) a graphic within a document**

1. Select the graphic by clicking on it once.
2. Move the mouse pointer to one corner of the selected graphic, until the mouse pointer changes to a line at 45 degrees with an arrowhead at each end.
3. Depress the mouse button and drag to resize the image within the document.
4. Release the mouse button.

### Delete a picture, image, chart

**To delete an image**

1. Click once on the image to select it.
2. Press the **Delete** key.
The Page Setup Dialog Box

The Document setup options are located under the File drop down menu and accessed via the Page Setup command.

![Page Setup Dialog Box](image)

Change document orientation – portrait or landscape. Change page size.

Page Size and Orientation
This feature allows you to control the paper size and orientation of a page. Here you can specify different sizes for your pages.

To select a page size for the paper you are printing to

1. Select the Page Setup command from the File drop down menu.
2. Ensure that the tab is selected so that the Paper folder is displayed and select the paper size you wish to use from the Paper Size drop down list.

To set the page orientation
To select the paper orientation, click on the Portrait or Landscape buttons in the Orientation section.
Change margins of entire document, top, bottom, left, right

**What are Page Margins?**
On any page, or in any position in a document, you can change the top, bottom, right and left margins. You can change margin settings for the whole document, for document pages from the position of the insertion point, or even for a single paragraph of a single page.

**To set margins using the Page Setup command**
• From the **File** menu choose the **Page Setup** command, the **Page Setup** dialog box is displayed. If it is not already displayed, select the **Margins** tab.

![Page Setup dialog box]

**Top**: To set the top margin.  
**Bottom**: To set the bottom margin.  
**Left**: To set the left-hand margin.  
**Right**: To set the right-hand margin.  
**Gutter**: To set the gutter margin width between pages to allow for binding etc.

**Preview a document**

**To preview a document**
• Click on the **Print Preview** icon. The Print Preview screen appears.  
• Click once in the document and the mouse cursor will change to a **Zoom** tool.  
  • Click on the document again

**The Print Preview Toolbar Icons**

- **Print**  
The document is sent to the printer.

- **Magnifier**  
The same as clicking inside the document. It gives a single-level zoom.

- **One Page**  
Single-page view.

- **Multiple Pages**  
Allows you to print preview up to six pages at a time.

**Printing**

• Click on the **File** drop down menu and select the **Print** command.

• Depress Ok
Printing

To specify what to print
Click on the File drop down menu and select the Print command.

Make changes as required within the Page range section of the dialog box.

- To print the entire document, click on All.
- To print only the page you are viewing, click on Current page.
- To specify the pages you wish to print, click on Pages and enter the pages which you wish to print.

E.g. if you want to print page 3, and also pages 5-7 inclusive, you would enter 3, 5-7

So.. 3, 6-7 means that it is going to print pages 3, 5, 6 and 7

To specify the number of copies required

Click on the up/down arrows to select number of copies to print.

You can also type the number yourself.
**Microsoft Excel**

A spreadsheet is made up of little boxes called **cells**.

Each column has a **letter** and each row has a **number**. The **cell reference** is the name of the cell - first the Column letter and then the row number. **Example**: B3

The file where you save is called the **Workbook**. A workbook can have many **Worksheets**. In the Example below, we only see Worksheet 1 of the Workbook. It has 3 Worksheets and you can click on the tabs below to select them.

A cell can have one of 4 types of data in it:
- **Text** - when it has words in it (example: A2)
- **Number** - when it has a number (example: C3)
- **Date** - when it has a date
- **Formula** - when you want to calculate something.
(Example: D3 - you can see the formula in the formula bar)
You can find the four mathematical symbols on the numeric keypad on the keyboard:

<table>
<thead>
<tr>
<th></th>
<th>Maths</th>
<th>Computer</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>+</td>
<td>+</td>
</tr>
<tr>
<td>4</td>
<td>-</td>
<td>-</td>
</tr>
<tr>
<td>0</td>
<td>×</td>
<td>*</td>
</tr>
<tr>
<td></td>
<td>÷</td>
<td>/</td>
</tr>
</tbody>
</table>

Typing a formula:

Always start with the equals sign =

In Microsoft Excel we **NEVER** type what is in the cell. We always type the cell reference.

**Example:** In our example (on the previous page), if we want to find the price of 3 T-shirts, we multiply the price of one T-shirt (cell B3) with the quantity (cell C3). We write this formula in cell D3:

= B3*C3

After that we press **Enter** on the keyboard and we can find the answer in the place of the formula.

To Delete *(biex thassar)*

1. **Highlight** *(immarka/aghžel)* the cell or cell range that you wish to delete.

2. Press the **Delete** button from the keyboard.
To Undo *(biex treqga’ lura dak li tkun hassart)*

Press the **Undo** button from the formatting toolbar.

To Redo *(biex terga’ lura ghal qabel ma ghabfast l-undo)*

Use the **redo** button if you want to get back changes removed by **undo**

To Double Underline

1. Click on the **Format** menu from the **menu bar** and select **Cells**.
2. From the Format Cells dialog box, select the **Font** tab.
3. From the Underline drop-down menu, select **Double Accounting** and press **OK**.

   Or else:
   
   1. Press **Shift** on the keyboard + **Underline button**

To Change the Background Colour

1. **Highlight** the cell or cells where you want to apply the shading.
2. Press the little black arrow near the **Fill colour button** to see the choice of colours available.
3. **Click** on the colour that you want.
To adjust Row height and Column width

To modify column widths to a specified value:

Select the column/s to adjust its width.
Click Format menu.
Point to Column.
Click Width…
Enter the width value.
Click OK button.

To modify row heights to a specified value:

Select the row/s to adjust its width.
Click Format menu.
Point to Row.
Click Height…
Enter the height value.
Click OK button.

You can also adjust the width of a column according to the longest data entry in that column:

Select the column/s to adjust its width.
Click Format menu.
Point to Column.
Click AutoFit Selection.

You can also adjust the height of a row according to the data entry in that row:

Select the row/s to adjust its height.
Click Format menu.
Point to Row.
Click AutoFit.

Or else:
You can double-click (instead of dragging) the places shown in the example above. This adjusts the column/row width according to the longest entry in that column/row.
**Adjusting Margins, Paper size & Orientation**

- Click **File** from the menu bar
- Choose **Page Setup**

When your spreadsheet is ready for printing, select **Print Preview** to see how it is going to print.

**Page Setup**

- **Orientation**: Choose Portrait (wieqfa) or Landscape orientation.
- **Paper size**: A4 (click here to change to paper size. We normally use A4 size paper.)
- **Print quality**: 600 dpi
- **First page number**: Auto

When your spreadsheet is ready for printing, click on this button to print.